通达信金三角主图指标公式

DRAWGBK(C>0, RGB(0,0,0),RGB(0,10,10),0,'0',0);{渐变背景}
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
SJ1:=(REF(HIGH,3) = HHV(HIGH,((2 * 3) + 1)));
SJ2:=FILTER(SJ1,3);
SJ3:=BACKSET(SJ2,(3 + 1));
SJ4:=FILTER(SJ3,3);
SJ5:=(REF(LOW,3) = LLV(LOW,((2 * 3) + 1)));
SJ6:=FILTER(SJ5,3);
SJ7:=BACKSET(SJ6,(3 + 1));
SJ8:=FILTER(SJ7,3);
SJ9:=((REF(LLV(LOW,(2 * 3)),1) + REF(HHV(HIGH,(2 * 3)),1)) / 2);
SJ10:=((HIGH + LOW) / 2);
SJ11:=(((SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10)))) OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ12:=(SJ8 AND NOT((SJ4 AND (SJ9 < SJ10))));
SJ13:=(SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10))));
SJ14:=(REF(BARSLAST(SJ11),1) + 1);
SJ15:=BACKSET((SJ11 AND (COUNT(SJ12,SJ14) > 0)),LLVBARS(IF(SJ12,LOW,10000),SJ14));
SJ16:=(SJ15 > REF(SJ15,1));
SJ17:=BACKSET(SJ16,2);
SJ18:=(SJ17 > REF(SJ17,1));
SJ19:=((SJ18 OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ20:=(REF(BARSLAST(SJ19),1) + 1);
SJ21:=BACKSET((SJ19 AND (COUNT(SJ13,SJ20) > 0)),HHVBARS(IF(SJ13,HIGH,0),SJ20));
SJ22:=(SJ21 > REF(SJ21,1));
SJ23:=BACKSET(SJ22,2);
SJ24:=(SJ23 > REF(SJ23,1));
SJ25:=BACKSET(BARSTATUS,(BARSLAST(SJ18) + 1));
SJ26:=(SJ25 > REF(SJ25,1));
SJ27:=BACKSET(BARSTATUS,(BARSLAST(SJ24) + 1));
SJ28:=(SJ27 > REF(SJ27,1));
底:=REF(LOW,BARSLAST(SJ26));
頂:=REF(HIGH,BARSLAST(SJ28));
STICKLINE(SJ26,頂,底,0,0),COLORBLUE,LINETHICK2;
DRAWLINE(SJ28,HIGH,SJ26,LOW,0),COLORBLUE,LINETHICK2;
DRAWLINE(SJ28,HIGH,SJ26,頂,0),COLORBLUE,LINETHICK2;
STICKLINE(SJ28,頂,底,0,0),COLORRED,LINETHICK2;
DRAWLINE(SJ26,LOW,SJ28,HIGH,0),COLORRED,LINETHICK2;
DRAWLINE(SJ26,LOW,SJ28,底,0),COLORRED,LINETHICK2;
红三角画完出局:DRAWTEXT((BARSCOUNT(CLOSE)=BARSTATUS=2),HIGH,' 红三角画完出局'),COLOR0000FF;
蓝三角画完介入:DRAWTEXT((BARSCOUNT(CLOSE)=BARSTATUS=2),HIGH,' 蓝三角画完介入'),COLORBLUE;
{牛股强势启动}
X5:=EXPMA(CLOSE,3);
X10:=EXPMA(CLOSE,7);
X20:=EXPMA(CLOSE,20);
五日斜率:=(X5-REF(X5,1))*100/REF(X5,1);
十日斜率:=(X10-REF(X10,1))*100/REF(X10,1);
二十斜率:=(X20-REF(X20,1))*100/REF(X20,1);
XX5:=XMA(五日斜率,4);
XX10:=XMA(十日斜率,7);
XX200:=XMA(二十斜率,20);
AA1:=XX200>=0.7 AND REF(XX200,1)<XX200 AND XX5> XX10 AND XX10>XX200
AND REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)< REF(XX200,2) ;
XX202:=XMA(二十斜率,22);
AA2:=XX202>=0.7 AND REF(XX200,1)<XX200 AND XX5> XX10 AND XX10>XX202
AND REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)< REF(XX202,2) ;
XX204:=XMA(二十斜率,24);
AA3:=XX204>=0.7 AND REF(XX200,1)<XX200 AND XX5> XX10 AND XX10>XX204
AND REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)< REF(XX204,2) ;
XX206:=XMA(二十斜率,26);
AA4:=XX206>=0.7 AND REF(XX200,1)<XX200 AND XX5> XX10 AND XX10>XX206
AND REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)< REF(XX206,2) ;
XX207:=XMA(二十斜率,20);
AA7:=XX207>=0.7 AND REF(XX207,1)<XX207 AND CROSS(XX10,XX207)
AND CROSS(REF(XX5,1),REF(XX207,1));
XX2071:=XMA(二十斜率,23);
AA71:=XX2071>=0.7 AND REF(XX2071,1)<XX2071 AND CROSS(XX10,XX2071)
AND CROSS(REF(XX5,1),REF(XX2071,1));
XX2072:=XMA(二十斜率,26);
AA72:=XX2072>=0.7 AND REF(XX2072,1)<XX2072 AND CROSS(XX10,XX2072)
AND CROSS(REF(XX5,1),REF(XX2072,1));
XX208:=XMA(二十斜率,20);
AA8:=XX208>=0.7 AND REF(XX208,1)<XX208 AND CROSS(XX10,XX208)
AND CROSS(XX5,XX208);
XX2081:=XMA(二十斜率,23);
AA81:=XX2081>=0.7 AND REF(XX2081,1)<XX2081 AND CROSS(XX10,XX2081)
AND CROSS(XX5,XX2081);
XX2082:=XMA(二十斜率,26);
AA82:=XX2082>=0.7 AND REF(XX2082,1)<XX2082 AND CROSS(XX10,XX2082)
AND CROSS(XX5,XX2082);
DRAWTEXT(AA1 OR AA2 OR AA3 OR AA4 OR AA7 OR AA71 OR AA72 OR AA8 OR AA81 OR AA82,L,'←牛股强势启动');
{}
DRAWTEXT_FIX(1,0,0,0,'★短线操盘纪律:三天线上穿十日线,量比大于2%,涨幅大于3%,大角度上行,,操作时间:上午10点前,或者下
午2点30后,目标盈利10%★'),COLORLIGRAY;
{}
CYC13:=0.01*EXPMA(AMOUNT,13)/EXPMA(VOL,13);
CYS:=(CLOSE-CYC13)/CYC13*100;
ASR:=(WINNER(C*1.1)-WINNER(C*0.9))/WINNER(HHV(H,0))*100;
AA:=CYS<16 && ASR<10 && CROSS(PSY.PSY,PSY.PSYMA) && PSY.PSY<20 && PSY.PSYMA<20 && C>O,NODRAW ;
DRAWTEXT(AA,L,'←抄'),COLORFF00FF;
{}
ZZ:=IF(REF(C,1)>REF(O,1) AND O>REF(C,1)*1.014 AND C<O*1.02,1,3);
V5:=MA(V,5);
V12:=MA(V,12);
V34:=MA(V,34);
C6:=MA(C,6);
DRAWTEXT(CROSS(C,C6) AND V>V5*1.2 AND V>V12*1.2 AND ZZ>2 AND C>H*0.975,L,'爆');

通达信金三角主图指标公式

通达信金三角主图指标公式的选股公式如下:

  • 通达信凹口起柱主图指标公式
  • 通达信铁定出局指标公式
  • 通达信高量柱灯塔线主图指标公式
  • 通达信量精灵指标公式
  • 通达信猴子爬杆主图及选股指标公式
  • 通达信均线和成交量捉主升选股指标公式
  • 通达信高量画线主图指标公式
  • 通达信长阴中阴量指标公式
  • 通达信涨跌判势主图指标公式
  • 通达信花开无声指标公式
  • 版权保护: 本文由股票配资网原创,转载请保留链接: http://www.hnminle.com/gppzgs-cd-168/66486.html